Inicio > Componentes, Delphi, Programación, RxLib > Sobre las RXLib (Recopilatorio)

Sobre las RXLib (Recopilatorio)

viernes, 27 de noviembre de 2009 Dejar un comentario Ir a comentarios
Share Button

Personalmente soy de los que llevo unos cuantos años utilizando las RxLib. Siempre me han parecido unas librerías muy buenas y estables.
Hace un tiempo realizé una traducción (no oficial) de la versión para Delphi 7, para traducirla a Delphi 2005/2006.

Desde ese día hasta hoy, no son pocos los programadores que se han puesto en contacto conmigo, vía correo electríonico o vía mi web para pedirme esa versión o para comentarme cosas sobre versiones posteriores.

Así que me he decidido ha hacer esta recopilación de diferentes versiones, oficiales, no-oficiales, recursos,…

Os adjunto también algo de información de cada una de ellas. En la mayoría de los casos datos del autor y poco más, extraídos de los fuentes o de los archivos TXT que incluyen.

(27/04/2017)
Jhonny, Administrador y moderador  de los foros del ClubDelphi, ha portado la ultima versión disponible en la página http://www.micrel.cz/RxLib/ a la versión 10. 2 Tokyo.
Aquí tenéis el enlace a blog donde podéis leer la entrada y descargar los fuentes, que también adjunto debajo de este mensaje.
 (20/12/2016)
En esta página podéis descargar versión no oficial para las últimas versiones de Delphi XE/, XE8, 10 Seatle y 10.1 Berlín.
 (13/01/2015)
Versión no oficial con fecha de Mayo del 2014 compatible con Delphi XE6
(28/03/2012)
Nueva versión no-oficial, de las RxLib. Revisión 1.08. Incluye soporte para la útltima versión de delphi (XE2) y segun el documento con las modificaciones, también soporte para 64 bits.

(02/02/2012)

Añadida versión no-oficial de las RxLib (2.75  build 1.07); Añade un componente nuevo y corrige algunos bugs de la anterior.  Según la documentación comprende versiones delde D2005 hasta Delphi XE2.

(13/09/2011)

Añadida versión “no-oficial” con soporte para Delphi XE2. Corregisdos algunos errores relacionados con Unicode y el componente rxMemoryData.

(18/03/2011)

Versión “no-oficial” de las RxLib que soporta DelphiXE. Esta incluye nuevas funciones y nuevos componentes (17 según leo). Podéis ver la los cambios principales introducidos en esta versión revisando esta página.

También he subido una recopilación de todos los recursos en los diferentes idiomas para la versión 2.75(Bulgarian, Chinese, Chinese (traditional), Czech, Danish, Dutch, French, Galician, German, Geek, Hungarian, Italian, Korean, Mexican, Polish, Portuguese, Romanian, Serbian, Slovene, Spanish, Slovak, Swedish, Turkish, Ukrainian).

(17/02/2011)

Versión (no oficial) para RAD Studio XE; Compilado sin problemas; Incluye packages para Delphi 6 y posteriores hasta RAD Studio XE, junto con las Demos y la ayuda.

____________________________________________________________

Versión para Lazarus.

Lagunov Aleksey (alexs)
ALEXS75-at-YANDEX-dot-RU

Versión 2.75 para versiones antiguas de Delphi y C++Builder

Los recursos traducidos a español de la versión 2.75

La últimas versión oficiales de las RxLib. 2.75. Comprimidas y con instalador.

qmd@usercontrol.com.br
http://www.usercontrol.com.br
icq: 15630894

Neftalí -Germán Estévez-. El que suscribe estas líneas.

Adapted: psa1974

Steve Jordi.

________________________________________________________

Os adjunto también este link, que permite acceder a la ayuda en línea, a partir de las imágenes de los componentes que aparecen en la paleta de las RxLib.

RxLib Help

AÑADIDO: Adjunto esta página (traducción automática al castellano) que también hace un recopilatorio de páginas ynoticias relacionadas con las RxLib. Está originalmente en ruso y traducida utilizando el traductor de Google.

Share Button
  1. xisco
    lunes, 28 de diciembre de 2009 a las 15:31 | #1

    He probado la versión 2.77 para Delphi 2010 y me he encontrado que los TRxMemoryData no funcionan bien cuando agrego registros no me graba valores correctos y tienen creo algo que ver con el addfields, lo raro es que se añaden bien hasta que se hace el post que el segundo campo entero creado no coge el valor correcto.

  2. Dioni
    viernes, 22 de enero de 2010 a las 12:39 | #2

    En primer lugar, muchas gracias por la recopilación.
    He descargado el zip de la versión 2.77 para Delphi 2010 y no puedo descomprimirlo porque parece ser que el fichero está corrupto. ¿Hay algún otro mirror donde descargarlo?

  3. Neftalí
    viernes, 22 de enero de 2010 a las 17:10 | #3

    Hola Dioni.
    He descargado la versión que comentas y me la ha bajado y descomprimido sin problemas.
    De todas formas, puedes probar en el FTP del ClubDelphi, donde también está los archivos:
    http://www.terawiki.com/clubdelphi/Delphi/Componentes-Funciones/__RxLib__/

    Un saludo.

  4. Dioni
    lunes, 8 de febrero de 2010 a las 10:36 | #4

    @Neftalí
    Muchas gracias Neftalí, ahora he conseguido descomprimirlo sin problemas.

    Un saludo

  5. Mauricio
    miércoles, 16 de febrero de 2011 a las 16:16 | #5

    Hola Neftali, he tratado de instalar los componentes para Delphi 2010, pero al compilar todos los paquetes, el paquete rxbde140 me muestra una ventana donde me dice q necesita remover RXQuery del rxdb140 para poder ser compilado, despues de aceptar (click OK, pues es la unica forma de q compile), el ultimo paquete (el dclrxbd140) me dice q no encuentra RXQuery.dcu y por ende no puedo instalar este ultimo,lo particular del caso es que hasta ahora solo me ha pasado en un solo equipo de 10 q he instalado los rxlib, tienes alguna idea de como pueda solucionar esto??

  6. Ramón
    sábado, 29 de octubre de 2011 a las 20:31 | #6

    El último enlace ( RxLib v. 2.75 1.03 D5 DXE2 ) tiene un archivo que parece que incluye todas las versiones desde Delphi 5 hasta Delphi XE2.

    Pero el archivo de información que incluye dice que incluye las versiones desde Delphi 2005 hasta Delphi XE2.

    Y muchas gracias, con tu recopilación ha sido fácil el instalar las RX para mí.

  7. Neftalí
    lunes, 31 de octubre de 2011 a las 10:28 | #7

    @Ramón
    Hola Ramón.
    Sí, he visto el fichero, pero también es verdad que están creados los packages para compilar todas las versiones y revisando el código de las units, aparecen DEFINES con referencias a Delphi6, Delphi5,…, así que me inclino a pensar que el error se encuentra en el fichero (tal vez por un Copy&Paste).
    De todas forma, no lo aseguro 100% por que no lo he probado.

    A ver si alguien que los haya instalado nos puede dar más detalles.

    Gracias por el comentario.

    Un saludo.

  8. viernes, 25 de noviembre de 2011 a las 16:32 | #8

    He usado muchos las RX, desde Delphi 7 hasta ahora la XE, pero encuentro un error que no veo que se haya solucionado en las nuevas versiones, y es que al usar la propiedad Filter (filtrado en memoria) no filtra (siempre con Filtered en true).

    Al final terminé comprando las KbmMemTable que para el uso son mucho mejores y las RX para el resto de componentes que tienen (sobre todo el FormStorage).

    Sabés si este es un error común de las rx (lo del filtrado) o ¿solo me pasa a mi?

    Gracias!

  9. Neftalí
    viernes, 25 de noviembre de 2011 a las 16:40 | #9

    @Arsenio Lupín
    Hola Arsenio;
    En cuanto al problema de las RxLib, que me comentas, la verdad es que no utilizo mucho este componente en concreto y lo poco que lo he utilizado ha sido hace bastante tiempo. No tengo noticia de esto, pero si quieres que te lo confirme, pásame un pequeño proyecto de ejemplo y los pruebo con las diferentes versiones que tengo.

    P.D: Gracias por el aviso respecto a los comentarios y felicidades por el Blog. Acabo de verlo, no lo conocía y ya he guardado la referencia para seguirlo; Espero que poco a poco la gente de habla hispana se anime a crear nuevos blog y a publicar contenido.

    Un saludo.

  10. Andres
    miércoles, 22 de agosto de 2012 a las 17:32 | #10

    uTiler.dcu
    Buenos Días, Que pena mi ignoracia, queria saber si ud de casualidad me puede solucionar una duda con respecto al componente que incluye el documento uTiler.dcu ya que me sale el siguiente error al compilar mi aplicacion:

    [DCC Fatal Error] UFrmCarteraWEB.pas(20): F1026 File not found: ‘uTiler.dcu’

    Gracias por su tiempo
    Andres Pineda

  11. Neftalí
    jueves, 23 de agosto de 2012 a las 08:10 | #11

    @Andres
    Ese error hace referencia a un componente que no existe en su sistema y sí en el proyecto. Quien ha realizado el proyecto debería saber de qué componente se trata (uTiler). Sólo con el nombre y sin saber nada más es difícil encontrarlo.

    Un saludo.

  12. Ficus
    sábado, 25 de agosto de 2012 a las 05:05 | #12

    Hola , mil disculpas por mi ignorancia…al compliar las rx para delphi xe ultima version ,,me daa el siguiente error …me podrian orientar…mil gracias de antemano…

    [DCC Fatal Error] RxIcoList.pas(380): F2039 Could not create output file ‘..\RxIcoList.dcu’

  13. Neftalí
    domingo, 9 de septiembre de 2012 a las 16:25 | #13

    @Ficus

    El error te está diciendo que no puede escribir el fichero DCU. Ya sea porque el directorio no existe, porque no lo puede sobreescribir,…

  14. viernes, 12 de abril de 2013 a las 01:28 | #14

    Neftali, felicitaciones por el blog, te cuento que baje las RX para XE3 y no encuentro ninguna ayuda de instalacion, compile y solo me falta el orden de instalación.

    Saludos

  15. Neftalí
    viernes, 12 de abril de 2013 a las 08:50 | #15

    @Bertifox
    Hola Bertifox.
    En los paquetes de componente que puedes descargar de aquí (y en otros también) hay un Grupo de proyectos que incluye todos los paquetes en el orden correcto.
    De todas formas, no es muy importante el orden, ya que la propia compilación te dará el orden correcto. Si compilas un paquete y necesita otro, este que compilas fallará; En ese caso lo “bajas” por debajo de los demás. Si vas probando llegará a uno que compila sin necesidad de los demás, ese es el que va primero.

    Otra forma, más exacta, de saber el orden correcto de los packages es abrir los ficheros DPK con un editor de texto. En cada DPK hay una sección requires que contiene los packages necesarios para compilar. De esta forma, por ejemplo, si abres el fichero DclRxCtl160.dpk, verás que en el requires está el package RtmRxCtl160. Eso significa que para compilar el primero necesitas el segundo, por lo tanto en el orden el segundo debe estar “más arriba” que el primero.

    Si repites esto con el reto de packages, tendrás el orden correcto.

    Un saludo.

  16. Alejandro Gabriel
    miércoles, 29 de mayo de 2013 a las 04:23 | #16

    Amigo Neftalí­ te dejo este sitio donde encontre una nueva versión de las librerías RxLib no oficiales. Es la versión 1.010 y en esta versión se incluye una carpeta con los fuentes para compilarlo en Delphi XE3.La última versión que tú has puesto en tu sitio no compila en Delphi XE3 si se intenta hacerlo con los fuentes de Delphi XE2.
    Saludos,El Rayo.
    http://www.micrel.cz/RxLib/

  17. Neftalí
    miércoles, 29 de mayo de 2013 a las 08:05 | #17

    @Alejandro Gabriel
    Gracias Alejandro.
    Lo reviso y las añadiré al recopilatorio.

    Un saludo.

  18. @NillGolv
    miércoles, 4 de diciembre de 2013 a las 12:55 | #18

    Porque nao compila? apresenta sempre este erro:
    Never-build package ‘RtmRxCtl160’ must be recompiled
    Required package ‘RtmRxCtl160’ not found

    Lbrary Path:C:\Program Files (x86)\Embarcadero\RAD Studio\9.0\lib\RxLib275_u108\unitsC:\Program Files (x86)\Embarcadero\RAD Studio\9.0\lib\RxLib275_u108\units\packages_DXE2

    Help me

  19. Neftalí
    miércoles, 4 de diciembre de 2013 a las 13:56 | #19

    @@NillGolv

    Me da la impresión de que tienes algún problema con los directorios donde se generan ls DCU, BPL y DCP.
    Estos errores suelen salir cuando encuentra versiones diferentes de los ficheros compilados (DCU, DCP, BPL). Revisa que no te esté encontrando ficheros en algunas carpetas que sean diferentes (más antiguos) a los que estás generando.

    Un saludo.

  20. Bismark
    lunes, 9 de diciembre de 2013 a las 20:04 | #20

    He instalado Rxlib 2.7 en XE4, pero tengo problemas con TrxMemoryData, no me guarda los datos, alguien sabe donde puedo bajar un RxLib que tenga corregido este Bug?????

  21. Leo
    lunes, 23 de diciembre de 2013 a las 21:36 | #21

    A mí me pasa lo mismo en XE5. No solo que no guarda al hacer el post, sino que al momento de asignar el valor, si el campo es string lo deja null y si es integer, lo deja en 0.

  22. Neftalí
    lunes, 23 de diciembre de 2013 a las 21:54 | #22

    @Bismark
    @Leo

    Los componentes RxLib están con los fuentes.
    ¿habéis probado a “debuggarlos” para ver si detectáis el error?

  23. Randall
    miércoles, 12 de noviembre de 2014 a las 05:46 | #23

    Hola Neftali, soy usuario de los RXlib desde delphi5, sin embargo ahora estoy trabajando con xe6 e instalé la versión 2.75, pero si el proyecto es para compilarlo en windows 64bits se inhabilitan las paletas y no puedo tener acceso a utilizar los controles que requiero. Si el proyecto es para compilarlo en 32bits funcionan perfectamente.

    Sabes que puedo hacer para poderlos utilizar en mis proyectos 64bits, aun y cuando los tenga que pagar. O bien, que me puedas recomendar algun pack de componentes que pueda jugar con las casillas currency, obvio, para xe7 y que permita ser compilado en 64bits?

  24. Neftalí
    miércoles, 12 de noviembre de 2014 a las 10:12 | #24

    @Randall
    Hola Randall.
    Hace tiempo que las RxLib se integraron en la librería de componentes JEDI. Tal vez deberías revisar estos a ver si han avanzado en ese sentido (64 bits). A priori están más actualizados y activos que las RxLib.
    Por otro lado puedes echarle un vistyazo a esta página (http://www.micrel.cz/RxLib/dfiles.htm) que es la que conozco que tiene las últimas actualizaciones sobre las Rx.

    Un saludo.

  25. jueves, 20 de abril de 2017 a las 15:05 | #25

    Hola>
    Quisiera saber si ya hay disponible una actualizacion de las RX para Delphi Tokio.
    Saludos.

  26. jueves, 20 de abril de 2017 a las 21:45 | #26

    @German Henao
    Hola.
    Hace tiempo que las RxLib se integraron en las Jedi. Puedes mirar si estas están disponibles para Tokyo.
    La otra opción es ir a esta dirección (http://www.micrel.cz/RxLib/dfiles.htm -sitio no oficial-) y probar con la versión que hay que funciona co9n 10.1 Berlín.
    Es probable que con nigún cambio o con muy pocos te compile sin problemas.

  1. viernes, 18 de marzo de 2011 a las 11:06 | #1
  2. viernes, 25 de marzo de 2011 a las 14:04 | #2
What is 22 + 4 ?
Please leave these two fields as-is:
IMPORTANTE! Para continuar, debes contestar la pregunta anterior (para evitar SPAM) :-)